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Editing a Combination with KARMA M50
and Merging the data with the M50
Revision 04-Sep-2011 © by Stephen Kay

This tutorial will explain the basic concepts of KARMA editing within KM50, the concept of editing in
two places at once (both KARMA M50 and the M50), and how to combine your edits into a finished
Combination or Program inside the M50. By following all of the steps, you’ll learn a lot about working
with many of the various windows and features of the KM50 user interface.

KARMA M50 (KM50) is not an editor for all of the parameters of the M50. It is the KARMA engine of the
M3 and OASYS, and all related parameters. It does not include any of the sound, track, timbre, and ef-
fect-related parameters that exist in the M50 itself – with the exception of two Drum Track parame-
ters, and the Program or Combi Category and name.

Typically, when you edit a Combi or Program in KM50 (a Multi-Module Performance or Single-Module
Performance, in KM50 terminology), you edit the KARMA-related parts in KM50, simultaneously mak-
ing edits to the sound, timbre, and track-related parameters in the M50 itself. These two sets of edits
“go together” to produce the final new version of the Combi or Program.

Once you have done this type of editing, you save the Performance in the KM50 software, and you
save the Combi/Program in the M50. Selecting the Performance in KM50 calls up the corresponding
edited Combi/Program in the M50, and if you plan to use it like this with the KM50 software, then
that’s really all you need to do. But if you want to get the edits to the name, category, and two Drum
Track parameters back into the M50 (rather than manually programming those on the M50), you must
learn the technique of merging the edits as explained in the later parts of this tutorial.

This example will use a Combi (a Multi-Module Performance), as we first edit the KARMA related set-
tings in the software and the timbre-related settings in the M50. The same operations apply for edit-
ing Programs (single-module Performances) – they’re just simpler.

The images shown here are from the Mac OS X version, but should be virtually identical on Windows.

A. Editing KARMA Parameters in the Performance

1. With KM50 launched and communicating with the M50, select Performance (Combi) C127 Mes-
ons & Quasars. You can do this by opening the Bank Display window for KDF row 2 Combi Bank
I-C (highlight and double-click or press Enter in the KDF Window), or by using the Bank and PE
menus at the top of the Performance Editor (Window Menu > Performance Editor (cmnd+P [mac],
ctrl+P [win])). Use Chord Trigger 1 to give it a listen so you know what it sounds like before we edit
it.
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2. Let’s change the GE for Module 1. Set the Status/Editing display at the top
of the Performance Editor to Module 1 if it is not already (you can also use
the Window Menu > Current Edit Module):

3. In the KDF Window, use the
scroll bar to bring the GE
Banks into view (or
lengthen the window), and
locate 15 GE Bank (1920
~2047), the 16th bank of M3
GEs. Double-click it, or se-
lect and press Enter, and a
GE Bank Display Window
opens, showing the 128 GEs
in that bank. Select GE 123
WaveSeq 1 (Bnd/Rpt).

4. Bring the Real-Time Controls Window to the front (you can use the Window Menu, or cmnd+L
[mac], ctrl+L [win]). By default, it should be displaying the Master Layer, as shown below. If you
wish, trigger KARMA with Function Key [F1] on your computer (or by clicking the button with your
mouse in the RT Controls Window) and listen to the changes as we perform the following steps.

5. Set Slider 7 WaveSeq Randomize to 64 (the KARMA Value will be 0 in the pop-up Parameter Dis-
play) as shown above.
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6. Now, select Module 1 from the Control Layer menu (you could also do this by clicking the tiny
numbers to the left side of the Scene Matrix Grid, or pressing [F12] on your computer keyboard).
This shows us the RT Control Layer for Module 1.

7. Turn on Switch 8 WaveSeq Offset, set Slider 5 Cluster Pattern to 46 (KARMA Value = 23), and play
[F1] (Chord Trigger 1) – you should hear a syncopated cyclic Wave-Seq pattern completely differ-
ent from the original.

8. Let’s edit it further: set Switch 3 Note Scale Type to On, and Switch 5 Bend On/Off to On, so that all
the edits shown above have been completed. Now there’s a cool note pattern going as well.

Note that you can solo a Module using the
tiny yellow Solo buttons at the top of the
Performance Editor, or the Solo Buttons in
the GE Setup Page, as shown to the right.
Try soloing Module 1 to hear your work so
far.
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If you haven’t opened it yet, try the Data Display
Window from the Window Menu (cmnd+D [mac],
ctrl+D [win]). Here you can clearly view the pan-
ning, bending, notes, and SysEx messages being
generated with Module 1 soloed. You will find the
Data Display Window to be quite useful when
trying to verify exactly what is being generated by
various modules.

If you play [F1], you will notice that, although the
stored chord is a minor chord, the note pattern is
playing a major riff. Why?

9 .  Go to the Performance Editor > Key Zones
page, press [F1], and you’ll see that the notes
for the chord, which are displayed in the key-
board above the zones, only have a single oc-
tave in the range for Module 1’s input. Some

types of GEs base their musical output on chord recognition of the input notes (and this happens
to be one of them). KARMA’s chord recognition interprets a single pitch as being a major chord.
So, in this case, where only two notes (both the same pitch) are going into the module as input, a
major riff is generated, even though the notes outside of the input zone are creating a minor
chord.

10. Edit the zone for Module 1 to include the whole range of the keyboard: you can click in the num-
ber box under “Top,” press and drag the mouse up, or type in ‘g9’, or click and drag on the range
bar display itself.

Now play [F1] again, and the other chord pads, and the notes of the pattern will follow the chords
instead of playing major riffs.
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11. Now, we’ll edit the other three Modules in a
similar fashion. Module 2 is playing the drums;
change the GE to 47 Mashed Garage [Dance
Kits], within the same bank.

Another way of selecting a new GE is from the
Performance Editor > GE Setup Page, using the
GE popup menu in the Module 2 column.

You could also use the Bank and GE popup
menus at the top of the GE Editor, assuming
that Module 2 is the “Current Edit Module”. The
Current Edit Module can be selected using the
tiny "Mod" buttons at the top of the GE or Per-
formance Editors, or by using the Window
Menu > Current Edit Module item.)

Finally, there’s an additional way to select GEs: We already opened a GE Bank Display in the first
part of this tutorial from the KDF file; it’s worth mentioning that from the GE Editor, you can click
the “Open GE Bank Display” button next to the GE Menu, and it opens the GE Bank Display Win-
dow containing that GE. You can select a GE in any GE Bank in the KDF File with this method as
well, loading it into the Current Edit Module. Note: the button above it next to the Bank Menu
brings the current KDF containing that bank to the front. This also works in a similar fashion in the
Performance Editor.
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12. In the Real-Time Controls Window, select the Control Layer for Module 2, and set Switch 5 Bend
On/Off to On, and Switch 6 Bend Normal/Arpeggiated to On, giving us a pitch-bended steppy ef-
fect on the drum groove. Use the Solo buttons to check it out.

13. For Module 3 (the bass), we won’t change the GE, we’ll just edit the Real-Time Controls. Change to
Module 3’s Control Layer using any of the methods we’ve preciously discussed, and make the fol-
lowing settings (you may wish to Solo Module 3 while doing this.)

Slider 7 Repeat Repetitions to 50 (KARMA Value = 3)
Slider 8 Repeat Transpose to 96 (KARMA Value = 12)
Switch 8 Repeat Volume/Decay to On (KARMA Value = 0/-6)
Switch 5 Bend On/Off to On (KARMA Value = 1)

As shown below, these settings give us some additional notes and octaves, with a bit of bending
as well.

14. Finally, let’s do something to Module 4, which at the moment isn’t even being played (as it’s
turned off.) Return to the Master Layer using the Control Layer menu, clicking on the small num-
bers, or pressing [F12] until it comes around again, and turn on Switch 4 Module Run [4] (as shown
in the diagram below). Now we can hear a string riff.
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Let’s choose a different scene for Module 4 as a starting point. There are several different ways to
choose a scene: the 8 large buttons directly under the Scene Matrix Grid choose one of the first 8
scenes for whichever Control Layer is currently selected. KM50 has 32 scenes per Module and Mas-
ter Layer, as shown by the Scene Matrix Grid above those 8 buttons. You can choose any scene in
any layer using the grid, which is similar to the Scene Matrix tab in the M3.

15.  Switch to the Control Layer for
Module 4, and click on Scene But-
ton 4 under the grid (you could
also click in row 4 of the Scene
Matrix Grid, column 4, or you
could use the Scene popup
menu). Now we have a busier pat-
tern, and the Sliders and Switches
update to the new values for the
scene.

16. As shown in the previous diagram, set Slider 5 Note Range to 108 (KARMA Value = 339) to increase
the octave range of the notes being generated on the strings. Set Slider 3 Duration Control to 60
(KARMA Value = 61/60) and Slider 8 Repeat Transpose to 96 (KARMA Value = 12) as well, to make a
more obvious part.

17. Let’s try out the Compare feature in KM50. From the Edit Menu, select Compare (cmnd+K [mac],
ctrl+K [win]). Press [F1] and you can hear the original Combi. Execute Compare again to return to
our edited version. This works basically the same as the M50 Compare feature, so be careful not to
edit anything while in the compared state or you will lose your edits.

Now, let’s save our work so far. You could overwrite into the same location, and then use “Save
As...” from the File Menu to create a new KDF file so that we haven’t overwritten the Preload KDF.
For the purposes of this tutorial, we’ll save the Combi into a new User Combi Bank in our Preload
KDF, and illustrate several concepts about how Performances match up with Combis and Pro-
grams in the M50. But we’ll also save it as new file, since it’s not a bad idea to keep a copy of the
Preload file in its unedited state.
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18. First, we need to add a bank to the KDF File. In the KDF window, select Combi Bank I-C as shown
below, click on the menu button (the KM50 Logo), and select “Add Bank...” In the resulting dialog,
select Performances (Combi), and click on the green checkmark (OK). A single new Combi Bank is
inserted after the highlighted bank, giving us Combi Bank I-D. A diamond symbol (Mac) or
asterisk (Windows) appears to the left of the KDF name in the title bar indicating it is edited.

 (KM50 will automatically add a bank of whatever type is not occupied already, so since we have Combi
Banks I-A, I-B, and I-C, the next available type is Bank I-D. But the order of Performance Banks in the KDF
Window is not fixed, they can be in any order, so if you didn’t select Bank I-C first, the new bank would
end up at the end of the list.)

19. Double-click the new Bank I-D in the KDF
File (or simply press Enter if it’s already se-
lected) to open the Bank Display Window.
Here we have the Bank Type popup menu
in the upper right corner, which is how you
associate a bank with a particular bank in
the M50. You can actually have more than
one bank of the same type in a KDF file, al-
though it’s not the best practice. Changing
the Bank Type will change which bank in
the M50 it is associated with – although we
do not need to change this setting now.

20. Back to the Performance Editor: click on the [Store] button
next to the Bank and PE menus. A dialog comes up allow-
ing you to choose a destination. From the Bank menu, se-
lect our new Combi Bank I-D (4th bank in the list), and
from the Location menu, select 000 (InitCombi ID000).
Add the number “2” to the end of the name, and change
the label to blue instead of none (just for the heck of it).

(Labels are a feature that allows you to visually identify different
Performances and GEs within the various Bank Displays. For exam-
ple, you could flag all edited Combis with yellow, or all work in pro-
gress with red.)
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Click OK (the green checkmark), and a warning is presented
that you are about to overwrite a Performance. (This warning
can be disabled in the Preferences > General tab, if you find it
gets annoying after awhile.)

Answer OK, and the Combi is written to I-D000, and you can see
it appear in the Bank I-D Bank Display Window.

21. Note that all you’ve done so far is write it into a location in the KDF File. But the KDF File itself
needs to be saved (you’ll notice it has a diamond or an asterisk next to the name in the title bar,
indicating it is currently edited.) From the File Menu, choose “Save As...”, give the file a name such
as My Performances.kdf, and press OK. The name of the KDF changes, and your data has been
saved as a new KDF File. Now that you have a new KDF File, any further edits can be saved into it
using the File Menu > Save command (cmnd+S [mac], ctrl+S [win]).

22. An important point needs to be made here: Select Combi I-D001 (Init) in our new Bank that we
created, and check the M50. It switches to Combi D001, as one might expect. Now reselect our
new Combi I-D000 Mesons & Quasars2. What happens? It selects the original Combi C-127 in
the M50. Why?

23. Switch to the Korg Page of the Performance Editor. Here, there are settings that specify a Bank and
Program Change that are sent when the Performance is selected.

Since we edited and stored a Performance that was referencing C127, the menus are still set to
send that program change.  Change the Bank Menu to Bank User D and the Prog/Combi menu to
000: Combi I-D000, and store the change by again pressing the [Store] button at the top of the
Performance Editor and overwriting the change into the same location. Note that you do not get a
warning dialog when overwriting into the same location; it assumes you are updating the same
Performance on purpose. Also, note that this entire step does not need to be performed unless
you have changed the location of the Performance, as we did here. If you had stored the edits in
the same place, there would be no need to change the Bank and Prog/Combi menus here.
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(Performances in KM50 are not necessarily constrained to relate sequentially to the corresponding Pro-
grams and Combis in the M50, but it’s actually wise to make sure they do so, for the purposes of im-
porting and exporting data. The reason for having this feature at all is that, if you are content with us-
ing the software, you could have multiple Performances that all call up the same Combi in the M50,
doing different variations or using different GEs. However, while this would work while using the soft-
ware, it could not be transferred to the M50 in any meaningful way. When the data is exchanged with
the M50, it is all based on sequential locations, and the Bank Type menu setting. So, it is recommended
to keep this arrangement for normal operation.)

24. OK, so now we have the Combi calling up I-D000, which is likely an INIT Combi (or the wrong
Combi). What do we do now? You could do either of these:

• Select I-C127 Mesons & Quasars in the M50, and use the Page Menu > Write Combination to
store a copy of it into D-000; or

• Since the KDF file contains the actual PCG data of the Combis and Programs as well as the
KARMA settings, we could send the Combi to the M50 using SysEx. This will also merge the
new name we gave it with the internal PCG data.

2 5 .  To try the SysEx method,
choose “Send Performance...”
from the Menu Button of the
Performance Editor. The re-
sulting dialog comes up pre-
configured to send the Current
Edit Buffer to the M50, so just
click on the green checkmark
(OK). The progress dialog will
show the SysEx being sent, and
if you watch the M50 Screen,
you will see it being written
into Internal Memory. The
name changes to D000 Mes-
ons & Quasars2.

At this point, the Combi is successfully stored in the correct location so that you can call it up
when you select it in the KM50 software.

26. Now, let’s try KM50’s Bypass feature. From the Options Menu,
choose “Bypass” (cmnd+  [mac], ctrl+  [win]). You will see
“[BYPASS]” labels turn on in several of KM50’s Editor windows,
to alert you to the fact that it is presently disabled, since it’s
sometimes easy to forget this.

Bypass does several things: it disables KM50’s KARMA genera-
tion capabilities, it enables the functioning of the M50’s in-
ternal Arp (which KM50 normally disables), and it toggles the
Local Control On/Off setting (in the M50 Global > MIDI page)
or other Thru options depending on settings in KM50’s Pref-
erences Editor.
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Note that you can still use KM50’s Function Keys to trigger the chord pads from your computer. How-
ever, if you check the Data Display Window, you will see that KM50 is not generating anything - the
M50’s internal KARMA Engine is back in control.

So now, you can play the Combi in the M50 itself, without any of the KARMA activity. The point is,
you can temporarily defeat KARMA and use the M50 normally without having to quit KARMA M50.

27. When finished, return operation to KM50 by turning off the Bypass feature under the Options
Menu, and verify that KM50 is again working by watching the Data Display Window and triggering
a Function Key Chord Trigger. Save the changes to your KDF file using the File Menu > Save com-
mand.

However, what if you wanted to edit not just KARMA, but some of the Program assignments, the levels
of the timbres in the Combi, and other timbre, sound and effect parameters?

That brings us to the next section in this Tutorial!

B. Editing sound parameters in the M50

In this section of the tutorial, we’ll edit some of the program assignments, levels, and timbre settings –
all of them things that are not possible to do directly from the KM50 Software, since it only handles
the KARMA-related parameters.

1. With KM50 Software again generating MIDI (Bypass Off), let’s change the sound of the bass (Tim-
bre 14). In the M50, on the Main Play page 0-2 [Prog 9-16], set Timbre 14’s Program to C-096 Har-
monic Bass. Then, since this program is an octave lower than the previous one, go to page 3-6
[Timbre Parameters > Pitch 9-16] and set Transpose to +12 for Timbre 14 (you may wish to Solo
Timbre 14 while doing this.)

2. This bass sound is clearly too loud; go back to page 0-4 [Mixer 9-16] and set the Volume of Timbre
14 to around 68.

3. From Page 0-2 [Prog 9-16], Change Timbre 10 (Drums) to E-076 Hard House Kit, and Timbre 13
(Drums) to E-067 Electro Rock Kit.

4. Change Timbre 15 (String Riff) to D-088 Vintage Sci-Fi Lead.

What do we do at this point to save these edits? It’s simple, because we haven’t done anything to
cause a “problem” yet.

5. Press [REC/WRITE] on the M50 and answer OK to write our edits into D-000 Mesons & Quasars2.
You may wish to stop KARMA first to avoid an annoying sound glitch.

At this point, we can play the Combi and all is well. However, we previously sent the PCG data to
this D-000 location in Section A of this tutorial, and we have now edited the Combi directly in the
M50 and saved it there. An issue arises if we now wanted to edit something that would cause us to
want to send the PCG data again (potentially overwriting what we just edited).
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C. Further KM50 Editing now that the M50 is edited

In this section, we’ll add some more edits to the KARMA settings, and a Drum Track Edit, creating a
situation where we want to send the Combi’s PCG data again.

1. In KM50, let’s set up another KARMA Scene. With the RT Controls Window in the Master Control
Layer, select Scene 2, either using the eight large Scene Buttons, or clicking in column 2 of the “M”
row of the Scene Matrix Grid.

As you can now hear, this doesn’t
sound very good, because it has the
default scene for Module 1’s GE,
which we loaded when we replaced
the GE. Since we edited Module 1 a
bunch to sound good earlier on, let’s
copy that scene to all the other
scenes as a starting point.

2. From the Menu Button in the RT Con-
trols Window, choose “Copy Scenes”.
We only want to copy Module 1 at
this moment, so set the Control Layer
popup menu to Module 1. We are
now in Scene 2; but Scene 3 was se-
lected for Module 1 in the previous
Master Layer Scene (go back and
check if you need to), so set the
Source Scene to 3, and the Destina-
tion Scene to “ALL”, and press OK.
This copies Module 1’s Scene 3 to all
31 other Scenes in that Control Layer.

3. However, something still doesn’t sound the same on Module 1 – that’s be-
cause Module 1 is also affected by the Master Layer settings. So let’s copy
the Master Layer Scene 3 into Scene 2, as well. Open the Copy Scenes dia-
log again, and set to Master, Scene 3, and Scene 2 as shown. This makes
Module 1 sound the same.

4. Now, let’s edit Scene 2 a bit. Turn off Module 4 (Synth Riff), and move Slider
2 Rhythm Complexity to 0 (KARMA Value = -99), which simplifies the drum groove, and shorten
the Durations of the bass and WaveSeq with Slider 3 Duration Control to 26, as shown in the fol-
lowing diagram.



Page 13

5. Let’s change the use of the Scene Change Quantize Window. Set it to “4 Bars”, and try switching
back and forth between Master Layer Scene 2 and Scene 3 – the scene change is delayed until the
next occurrence of the 4 bar window. You will see the Scene Matrix Grid and eight large Scene
Buttons blink red during pending scene changes.

6. Finally, let’s transpose all of the Chord Triggers. Click on
the [Edit] button in the Chord Triggers section of the RT
Controls Window, or select “Chord Triggers” from the
Window Menu (cmnd+J [mac], ctrl+J [win]).

You can see a column for each of the Chord Trigger but-
tons, containing the notes and velocities. At the top is the
“Transpose & Modify Velocity” section. This allows you to try real-time modifications to all, or one
or more, of the Chord Triggers, and then apply those settings to the specified Chord Triggers.

7. As shown below, set the Semitones menu to +1, Modify Velocity to Absolute, and Value to 117.
Press the Chord Trigger buttons (or use function keys [F1]~[F8] – they are now in the key of Fmin,
not Emin. The press the Set Values Button, and watch in the bottom portion of the window as the
chords transpose and all velocities become 117.
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8. Now, let’s add the use of the Drum Track. KARMA M50 allows you to control two of the Drum Track
parameters as a convenience: the Drum Track On/Off button, and the DT Trigger Mode setting.
These are in the lower right corner of the Real-Time Controls Win-
dow. With KARMA turned off (use [F9] or the On/Off button in the
RTC Window, or use the Arp button on the M50 if you have the M50
set up for Real-Time Control of the software), turn on the Drum
Track button in KM50. Because the DT Trigger Mode is set to “Start
Immediately” at this moment, you should see the Drum Track but-
ton in the M50 light up and hear the Drum Track pattern play.

9. Change the DT Trigger Mode to “Wait For Kbd Trigger” – the Drum Track button automatically
turns off and the Drum Track Stops. Turn the Drum Track button back on, and you will see the
Drum Track button blinking in the M50. Now press [F1] to trigger just the Drum Track.

10. It seems the Drum Track only plays as long as we hold the Chord Button. That’s because the Drum
Track Latch is turned off in this Combi. Since this is not one of the Drum Track parameters that
KM50 allows us to edit, go to the M50’s P7-7: Arpeggiator/Drum Track [Drum Track] tab, and turn
the Latch parameter on. Now, you should be able to trigger the Drum Track and have it continue
playing.

11. Stop the Drum Track, and switch back to Scene 2. Turn off Module 2 in the Master Layer (the
KARMA Drums.) Turn KARMA back on, turn the Drum Track on (blinking), and now you can trigger
KARMA and the Drum Track at the same time. You will hear just the Drum Track, along with two of
KARMA’s Modules (but not the KARMA Drums, since they are turned off.)

12. Switch back to Scene 3, and we have the KARMA Drums and the Drum Track at the same time.
However, there is yet another feature: KARMA can control whether the Drum Track is on in a given
scene. So in this case, it’s busy enough with the KARMA Drums and we don’t need the Drum Track
at the same time; let’s have it turn off the Drum Track in Scene 3.
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13. At the top of the Scene Matrix area in
the RTC Window, the topmost row is
name “DTrk” – if the cell is on in this
row, the Drum Track plays (if it is set
in the M50 to be used in the combi). If
it is turned off, then the Drum Track is
muted (it is still playing inside the M50, you just cannot hear it). This allows it to be turned back on
by Scene changes. Turn the DTrk cell in column 3 (Scene 3) off as shown above.

14. Now, with the Drum Track button and KARMA both on, trigger the combi and switch back and for
the between Master Layer Scene 2 and 3 – you will hear the KARMA Drums and the Drum Track
trade-off in the two scenes.

15. Return the Master Layer to Scene 3 (in the RT Controls Window) if it is not already, and stop
KARMA by pressing the Return Key of your computer keyboard. Note that the Drum Track stops as
well, and returns to blinking on the M50.

16. Let’s change the category and the name of this Combi just for the heck of it, and to illustrate an
upcoming point. In the Performance Editor > Korg Page, change the category to “Keyboard”, and
then save the Performance using the [Store] button as we’ve already done, changing the name to
“Particles & Waves”, overwriting the current Performance. Then save the KDF File from the File
Menu.

17. Furthermore, don’t forget we’ve edited a Drum Track setting in the M50, so save this as well using
[REC/WRITE].

At this point, we now have a situation where we have edits in the M50 to the timbre settings (pro-
grams, levels, pitch transpose, etc.), and we have edits in the KM50 software to the Drum Track set-
tings, the Combi Name and the Combi Category. If we were to send the Performance from KM50 to
the M50 as we did before at the end of Section A, it would overwrite all of the changes we just made
inside the M50 with the old version of the data (that is stored in the PCG part of the KDF file). If we
simply “got” the data from the M50 via SysEx into the current location of KM50, it would destroy the
new KARMA edits in KM50 by replacing them initialized KARMA data. Here is where we need to “get”
the edits from the M50 via SysEx, and “merge” them into the KM50 Data, so that the new PCG edits are
merged with the KARMA data in the Performance, and the two Drum Track settings. Then we can send
back the combined/merged data via SysEx.

D. Merging the edits and transferring it back to the M50

We have edited a number of KARMA settings in the Performance in the KM50 software, and it is play-
ing a Combi on the M50 that has edits to the timbres. In this section of the tutorial, you’ll learn how to
combine these two separate things, and get it back into the keyboard so they are synchronized.

1. To start with, always make sure both things are saved. Save the Performance in KM50, and write
the edits to the Combi into the M50, in the same location.
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2. From the Performance Bank Dis-
play Menu Button, choose “Get
Performance....” When the dialog
opens up, it will be set to the cur-
rent Performance (Combi D-000)
as a source. In the Destination
area, make sure the “Merge Loca-
tion” option is selected (very im-
portant!) which is the default set-
ting, with the destination being
the current Performance as well.
This tells it to get the Combi from
the M50, but to not replace the
KARMA part of this Performance.
(If you were to use the Replace
option, it would replace our cur-
rent KARMA settings initialized
KARMA data, since the M50 doesn’t have any internal KARMA settings to receive.)

3. Press OK (green checkmark) to close the dialog and request the dump. The progress bar comes up
and SysEx is received by KM50 (it will flash quickly if using the Korg USB Driver.)

Now, the edited PCG data from the M50 has been merged with the edited KARMA data in the KDF
file. (You will see that the KDF file has been marked as edited in the title bar of the KDF window.)
How do we get this back into the M50, with the new name, category, and Drum Track settings? We
just send it back, now that they have been merged.

As we did in Section A, from the
Performance Editor Menu Button,
choose "Send Performance..."
Since the Performance is pres-
ently loaded, you can leave the
options as set by default, which
sends the contents of the Edit
buffer to the currently selected
location in the keyboard. You can
see a message on the screen of
the M50 as it writes to internal
memory.

Now, test the combi and if everything went according to plan, you should be able to see that the
Combi still has all of the program edits we did, while incorporating the new name, category, and
Drum Track settings.
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The End!

Well, if you made it this far, thanks for sticking with it - you now should have a pretty good under-
standing of how to start editing a Program or Combi in KM50 Software, and be able to get anything
you’ve done in KM50 back into the keyboard. Well done!
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