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Creating GEs with the
Import To GE Editor
Revision 09-Jun-2015 © by Stephen Kay

This tutorial explains how to use KARMA Software’s “Import To GE Editor” to create GEs from simple
recorded MIDI Phrases and store them in the KDF File. If you work through these four short examples
(2 Drum Grooves, and 2 Melodic Phrases), you will gain an understanding of how all the parameters
work. For a detailed explanation of each parameter, see the KARMA Help File > Import To GE Chapter.

The editor presently allows you to import a phrase and turn in into a GE Type “Drum”, with either
drum notes or melodic data. See the next page for a description of the GE Editor: Drum Page.

To open the editor, choose Window > Import To GE. The key concept with this editor is that:

• You can leave the window open as you try importing things and move around the application.
• It imports a file and keeps the data in memory temporarily so you can repeatedly try different

settings if you want.
•  It shows you some analysis data of the pattern, and shows how many rows will be used in each of

the three Drum Pattern grids, and the "analysis" changes when you change settings, so you can
"optimize" the results.
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Brief Explanation of the GE Editor: Drum Page

Note that all of the following discussions about patterns, 7 notes per grid etc. relate to the fact that we
are creating a GE Type “Drum”, with either drum notes or melodic data. The three patterns and pattern
grids discussed here appear in the GE Editor > Drum Page:

As shown above, in a typical Drum GE (RTC Model Type DP1 – Drum/Perc), there are three Drum
Pattern grids, each capable of holding seven notes and a rest marker (bottom orange row). Usually,
kick/snare/toms are on Pattern 1, cymbals and hi-hats are on Pattern 2, and percussion and other
noises are on Pattern 3. In Melodic Drum GEs (RTC Model Type DM1 – Drum Melodic), notes are spread
across the three grids, such that the patterns can be activated individually or together and create
different combinations of notes.

Note: to avoid potential confusion, it’s worthwhile to note that the note numbers displayed on the rows of
the patterns may not always be what is generated, due to the use of the Note Map feature which can remap
any output note to any other output note. It is common in many combis for the Drum GEs to be running
through a Note Map in order to change certain drum notes into other ones.

In the following examples, we will discuss various ways of controlling which notes end up on which
pattern grids. Don’t worry if you don’t understand all of the technical jargon in some of the
descriptions of GE parameters – you can perform these operations without knowing all about the
internal workings of a KARMA GE, and later some of these descriptions will make more sense.
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Example 1 (Drums)

1. Launch KARMA M50 Software, with the M3 Preload for M50.kdf file.

2. Select Program A011 Funk Kit (from KDF Bank 3). You can do this in one of two ways:

A. From the KDF Window,
double-click (or select
and press Enter) the
fourth Performance
Bank, “3 Program Bank
I-A”. A Bank Display
window opens for that
bank, and you can
select A011 Funk Kit.

B. At the upper left of the Performance Editor (Window Menu), you can use the popup menus to
select the fourth bank, and Program A011 Funk Kit.

3. KARMA should be on by default for this program; if not, press function key [F9] on the computer
keyboard, or using the On/Off button in the Real-Time Controls Window (Window > Real-Time
Controls.) Verify that it plays the drum groove, i.e. by playing Chord Trigger 1 from the computer
keyboard [F1]. (Function Keys [F1] to [F8], and Shift + [F1] to [F8] are assigned to Chord Triggers 1
to 16, while [F9] is assigned to the On/Off switch. On Mac OS X, you may need to change the
default settings for the way the function keys work to take advantage of KARMA’s shortcuts. For
more details on key shortcuts, see the Help Menu > Keyboard Shortcuts chapter.) You can also use
the mouse, of course. Use the Return key to stop KARMA without actually turning it off.
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4. From the Window Menu, select "Import To GE" (Mac cmnd-E, Win cntrl-E) and the window opens.
At first, it will say (in the Analysis Area):

*** NO DATA LOADED ***

Use the [Select New File] button.

5. Click the [Select New File] button at the bottom, and locate the example files included with this
tutorial. There is a folder named "Tutorial Files" containing several .MID files located at (in a default
installation):

Mac OS X: Applications/KARMA M50/Tutorials
Windows: Start Menu > All Programs > KARMA M50 > Tutorials

Load the one named: “Drum Groove 1.mid”.

6. After doing so, the pattern’s analysis will appear in the Analysis Area. There is a button at the
bottom named [Play Original] – it will play the imported data that is in memory, so you can hear
the full original pattern. It’s not exact, as it is quantized to 24 cpq, not the original pattern’s
resolution, but it gives you an idea of what the pattern sounds like, if there’s a fill at the end, etc.

Let's examine the Analysis Area as to what it tells us:

File Name: Drum Groove 1.mid,   1314 Bytes

--------------------------------------------------

SMF Format 0, Number of Tracks 1, Resolution 480

Tempo 120.00, Time Sig 4/4, Last Event 5.1.000

Expected number of steps 64

First, you see the name of the pattern currently imported, and some info about it. The most important
thing at the moment is the "Last Event" - this shows that the pattern is a 4 bar phrase. Sometimes this
will have an extra note on the next downbeat, i.e. 5.1.000, sometimes a pattern will show 4.4.360 or
something like that. It's still considered a 4 bar phrase.

=================================================================

row  note  drum sound  velLev times loVel  hiVel  avgVel rowVel

--[Pattern 1 - Drums]------------------------------------[   0]--

 6   52 E_3 - Snare 2   [2]     2     25     54     39     -81

 5   52 E_3 - Snare 2   [0]     2    120    120    120       0

 4   50 D_3 - Snare 1   [2]     3     26     31     28     -92

 3   50 D_3 - Snare 1   [0]     6    120    120    120       0

 2   48 C_3 - Kick 1    [1]     6    102    108    103     -17

 1   48 C_3 - Kick 1    [0]    12    120    120    120       0

--[Pattern 2 - Cymbals]----------------------------------[ -20]--

 3   58 A#3 - HH Open   [2]     4     54     64     56     -44

 2   54 F#3 - HH Closed [2]    32     36     74     51     -49

 1   54 F#3 - HH Closed [1]    12     96    108    100       0

The above shows us the notes that will be split into the first two Drum Patterns, based on the settings
of the "Split into Patterns" and "Split Into Rows" sections. It shows which row in each pattern the notes
will go to, and some other things:

note - the MIDI note number of the row.

drum sound - the drum sound related to that note, based on a GM drum map. (Note: as Korg Drum Kits
do not entirely match the layout of a GM kit, the displayed name may not always be the exact sound).
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velLev - when a note is split into up to three rows by velocity, it shows which level of the 3 available
levels the row corresponds to, where velLev[0] are the loudest notes, velLev[1] are the mid level notes,
and velLev[2] are the softest notes.

times - shows how many notes will be in that row (across the pattern).

loVel - the lowest velocity note that will be included in that row.
hiVel - the highest velocity note that will be included in that row.
These two pieces of information can be used to "optimize" the split by velocity threshold settings and
arrive at better approximations.

avgVel - this shows the average velocity of all notes in that row, which is how they will be played by
KARMA.

rowVel - shows what the resulting Row Velocity Offset will be. The number at the top in each pattern’s
name row in brackets (i.e. [-3]) is the overall Pattern Velocity Offset. If the “Optimize Velocity Offsets”
checkbox is Off, this value will be [   0] and the Row Velocity Offsets will show the exact calculated
settings for each row; if “Optimize Velocity Offsets” is On, the value may be negative and the Row
Velocity Offsets will be increased by that amount, so that at least one row is at 0, and one Pattern is at
0. (All Row Offsets will be raised to be as close to zero as possible, while maintaining the relative
distance between each row in each Pattern. See the Parameter Reference for more info on this
setting.)

Continuing:

--[Pattern 3 - Perc]-------------------------------------[  -3]--

13    93 Open Triangle  [2]     4     50     58     53     -64 *

12    92 Mute Triangle  [2]    12     51     74     62     -55 *

11    92 Mute Triangle  [1]     6     77     95     85     -32 *

10    76 Low Conga      [2]     2     51     74     62     -55 *

 9    76 Low Conga      [1]     8     76     99     86     -31 *

 8    76 Low Conga      [0]     1    111    111    111      -6 *

 7    75 Open High Conga[2]     2     46     72     59     -58

 6    75 Open High Conga[1]     4     78     82     80     -37

 5    74 Mute High Conga[2]     2     68     68     68     -49

 4    74 Mute High Conga[1]     4     78    105     89     -28

 3    74 Mute High Conga[0]     2    117    117    117       0

 2    66 Tambourine     [2]    22     49     72     60     -57

 1    66 Tambourine     [1]     6     78    110     99     -18

--[Summary]------------------------------------------------------

Pat 1, rows required = 6

Pat 2, rows required = 3

* Pat 3, rows required = 13, 6 notes will be skipped

** Total Rows Required = 22, 6 notes skipped

Above is the info for Pattern 3, and a “Summary” section – the various red rows show us that there are
just too many percussion notes to import into seven rows. All of the red * rows would be ignored.
However, this is where you say "OK, now how can I optimize the settings to get the whole pattern?"

7. The answer is: Turn OFF the checkbox for Pattern 3 under “Split Into Rows”. Now, instead of each
note taking multiple rows at different velocity levels (for the third pattern), each note gets a single
row and they are all able to fit. The Analysis Area updates to show the new prediction and all of
the red lines disappear.
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8.  So, now that the data is adjusted, choose a location to
store the GE, using the Bank and GE menus at the bottom
left. You may wish to create a new User GE bank first (KDF
Window > Menu Button (the KM50 icon) > Add Banks), or
you can store it in one of the Init GE locations in the
included GE User Bank R – in this example, I’m using the
default of location 0 in GE User Bank R.

9. Open the GE Editor (optional) and set to the Drum page. Go back to the Import To GE Window,
press the Execute button at the bottom right, and watch the data appear in the GE Editor. Now
you can try it out – no need to shut the Import Window. In fact, you can keep changing
parameters and pressing Execute – it keeps the last loaded sequence data in memory. Notice that
the RTC Model has been automatically applied to the GE. You can open the Real-Time Control
Editor and immediately start playing with the RTC Model, same as other GEs. Try adding Repeat
Repetitions with Slider 7, arpeggiated bend with Switches 5 & 6, simplifying the groove with Slider
3 Note Randomize, etc.

Note: To get the correct drum note names in the GE Editor Drum Page (at least closer to correct) for Korg
Drum Kits, open the Preferences, choose the Popups tab, and set Drum Name Popup Menus to “Display
Names +12” – or choose “Shift Drum Names +12 (Korg)” from the Drum Page Menu Button.

10. Note that the “Create Velocity Pattern” checkbox is on by default (in the Import To GE Window),
along with the first pattern selected. What this does is attempt to use the difference between how
the notes are played in the actual sequence data, and how KARMA will generate them, to create a
Velocity Pattern that will then be applied to the selected pattern, to try to get more velocity
nuances. You can see the result in the pattern grid of the GE Editor Velocity page.

Example 2 (Drums)

Here, we will deal with importing an 8 bar loop that has a fill at the end. Normally, since there are a
max of 64 steps in the drum patterns, depending on the default settings, it would only get the first 4
bars and you would not be able to get the fill. But you can tell it to skip the middle of the pattern and
take the beginning and the end fill, and automatically set the Phase Pattern to make it into an 8 bar
phrase, similar to what it really is.

1. Click the “Select New File” button, and load the one named Drum Groove 2.mid. Let’s look at the
Analysis Area:

File Name: Drum Groove 2.mid,   1372 Bytes

--------------------------------------------------

MF Format 0, Number of Tracks 1, Resolution 480

Tempo 120.00, Time Sig 4/4, Last Event 8.4.360

Expected number of steps 128

The important thing to notice here is that the “Last Event” is 8.4.360 – this tells us that this is an 8 bar
drum loop (1.1.000 ~ 9.1.000). Of course, we can hear that using the “Play Original” button as well.
Furthermore, we can see that the expected number of steps (128) would be way over the 64 steps of
the pattern. Therefore, if we import it now, we would lose the second half of the pattern and the fill.

2. Change the “Import Bars” parameter to “1 x - - x”. This tells it that we will import the first 2 bars,
and the last 2 bars, thereby getting the fill. Note that the Analysis Area changes now, because
more drum notes (a tom fill) are included in the final pattern. In addition, the “expected number of
steps” changes to 64.
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3. Notice that the “Phase Pattern” parameter is set to “3 x---x---x---x---“ by default. (The ‘x’ marks
indicate where, an a 16 bar phase pattern, the drum pattern will be restarted, with the dashes
indicating a step with no restart.) This setting allows the full pattern on the grid (which is 4 bars
long by default) to be played through each time. For this example, set it to “2 x-x-x---x-x-x---“,
which tells it to set the Phase Pattern Drum “pr” buttons (pattern restart) so that the first 2 bars of
the pattern are played 3 times, followed by the last 2 bars, giving us an 8 bar phrase with a fill at
the end. In other words, the pattern is restarted 3 times in a row such that you only hear the first
two bars of it three times followed by the fill, when it is allowed to play all the way through. We
will take a look at this visually a bit later on. Continuing with the Analysis Area:

row  note  drum sound  velLev times loVel  hiVel  avgVel rowVel

--[Pattern 1 - Drums]------------------------------------[   0]--

 8   60 C_4 - Hi Tom 2  [1]     1     95     95     95     -25 *

 7   59 B_3 - Mid Tom 1 [1]     1     97     97     97     -23

 6   57 A_3 - Mid Tom 2 [0]     1    120    120    120       0

 5   55 G_3 - Lo Tom 1  [2]     1     73     73     73     -47

 4   55 G_3 - Lo Tom 1  [0]     1    120    120    120       0

 3   48 C_3 - Kick 1    [1]     2    103    108    105     -15

 2   48 C_3 - Kick 1    [0]    11    116    124    119      -1

 1   43 G_2 - Sticks    [0]     7    120    121    120       0

4. Notice that there is one note too many in Pattern 1 (one of the toms). However, by looking at the
velocity information, I can guess that something could be combined without completely
removing the velocity to the rows like we did in the last example. So in the “Split into Rows”
section, change the “Velocity Threshold (lo/hi)” for Pat 1: Drums to 76/125 – you will get the kick
down to one row, and now the other row fits.

5. Turn back ON the checkbox for “Pattern 3 Percussion” under Split Velocities by rows (if off from the
previous example).

6. Press Execute, and try it out. Notice that the fill happens in the eighth bar, like the original pattern,
because of the settings we made (watch the LED tracking arrays under each drum pattern in the
GE Editor, and see how they restart 3 times before continuing through the end of the pattern to
play the fill). Check out the Phase page of the GE Editor, as to how the yellow “pr” buttons are set
in the three Drum Pattern areas – this causes the restarting behavior.

Important note: These two drum examples used phrases that
were specifically created for the Korg Drum Map, which is
basically a Standard MIDI Map raised by an octave. In the “Split
Into Patterns” section of the window, there is a parameter
named “Drum Map,” which is set by default to “GM +12 (Korg)”.
However, if you are importing your own phrases from Standard
MIDI Files that were not created to go with Korg’s map, the
splitting of the pattern into kicks/snares, cymbals, percussion etc.
will not work correctly. In this case, you need to select the other
Drum Map, “GM”.
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Example 3 (Melodic Data)

Here we will import a very simple melodic phrase comprised of seven or less pitches.

1. Select a Bass Performance from inside the KM50 application and KDF file – for this example, select
C119 Stinger Bass. Verify that it plays the KARMA Groove (turn on KARMA in the Real-time
Controls Editor if necessary). Use the Return key to stop it.

2. If the Import To GE Editor is not already open, choose it from the Window Menu.

3 .  IMPORTANT: Change the “Interpretation” popup to “Melodic
Data”. This tells it that we are creating a melodic phrase that we
want to track around the keyboard and follow chord changes,
not a fixed drum groove that doesn’t transpose. In addition, this
influences how things are displayed in the Analysis Area, and
how some of the other parameters function.

The settings are automatically restored to the default settings for a Melodic Drum GE. Note that
you can also press the [Default Settings] button near the bottom at any time to restore the proper
initial settings for a Drum GE vs. a Melodic Drum GE if you have edited any of them.

4. Use the [Select New File] button to locate and select the file named “Bass Line.mid”. Press the [Play
Original] button to hear the phrase on the current program. Notice that the phrase has been
written in the key of Cmaj7, even though it was originally a min7 phrase. This is an important point
– If you want the data to make sense and track chord changes on the keyboard, you need to write
or transpose the phrase to Cmaj7 before importing.

5. Let’s take a look at the Analysis Area:

File Name: Bass Line.mid,   241 Bytes

--------------------------------------------------

SMF Format 0, Number of Tracks 1, Resolution 480

Tempo 120.00, Time Sig 4/4, Last Event 3.1.000

Expected number of steps 32

=================================================================

row    note    velLev times  loVel  hiVel  avgVel  rowVel

--[Pattern 1]--------------------------------------[   0]--------

 5    55  G_3   [0]     2      93    105     99      -10

 4    53  F_3   [0]     2     105    114    109        0

 3    52  E_3   [0]     2     105    111    108       -1

 2    48  C_3   [0]     5     108    114    109        0

 1    47  B_2   [0]     2     105    114    109        0

--[Pattern 2]----------------------------------------------------

--[Pattern 3]----------------------------------------------------

--[Summary]------------------------------------------------------

Pat 1, rows required = 5

Pat 2, rows required = 0

Pat 3, rows required = 0

Total Rows Required = 5

As we can see, this is a 2 bar pattern (ending on 3.1.000) and there are five notes in the original
pattern. Let’s try to get up to seven, just to fill the first grid at least, and get a bit more velocity nuance.



Page 9

6. Turn on the “Split Into 3 Rows by Velocity” checkbox. Now it jumps up to nine notes, and spills
over onto the second pattern. However, we don’t really want to do that; having two notes on the
second grid will not work well for turning on and off the three patterns from the Control Surface
and RTC Model. It will be better to try and get as many rows as possible in the first pattern, leave
the others empty (and the RTC Model algorithm will fill them with a variation of the first pattern.)

7. Start lowering the “Threshold hi” value. As you hit “”105”, it jumps from 8 notes down to 6, which is
the best we can do.

8. Press the Execute button to examine the results in the GE Editor, and play with it on the keyboard,
trying out different chords. Play a minor 7 chord and listen to the results – this was actually the
original phrase. The correct RTC Model has already been applied to it, and everything is set up to
produce useful results in the Real-Time Controls Editor. Try adding Repetitions (Slider 7), make
them louder (SW8), while turning Force Mono on (SW1), adding in the other two patterns (SW3,
SW4 - which are system-generated variations of the first one, since only one pattern was filled), the
bend settings, etc. I purposely chose a polyphonic bass program to more easily demonstrate the
function of the Force Mono button – you will want this on most of the time (for a bass GE at least).
Nevertheless, try it with some monophonic Bass programs – you will get some interesting results
with it in either position.

9. Notice that since the Create Duration Pattern button was checked by default, a Duration Pattern
has been created to simulate the durations of the original phrase – you can view this in the GE
Editor Duration page. Play with the Duration Slider in the Real-Time Controls Editor to adjust and
vary.

Example 4 (Melodic Data)

Here we will import a slightly more complex melodic phrase that needs to span two patterns.

1. Pick a Bell Performance such as Program I-C002 Silver Solar Bells from within KM50 and the KDF
file. Turn on KARMA if necessary and verify the GE is working.

2. Press the [Select New File] button and locate the file named “Melodic.mid.” Try it out with the [Play
Original] button (note again that the riff is in Cmaj7 tonality.)

3. Press the [Default Settings] button to return to the default settings for Melodic Data.

File Name: Melodic.mid,   444 Bytes

--------------------------------------------------

SMF Format 0, Number of Tracks 1, Resolution 480

Tempo 120.00, Time Sig 4/4, Last Event 2.4.360

Expected number of steps 32

=================================================================

row    note    velLev times  loVel  hiVel  avgVel  rowVel

--[Pattern 1]--------------------------------------[   0]--------

 7    64  E_4   [0]     3      90     93     92      -23

 6    62  D_4   [0]     1     102    102    102      -13

 5    60  C_4   [0]     2     105    105    105      -10

 4    59  B_3   [0]     1      99     99     99      -16

 3    55  G_3   [0]     2     111    111    111       -4

 2    52  E_3   [0]     2     105    114    109       -6

 1    48  C_3   [0]     2     114    117    115        0

--[Pattern 2]--------------------------------------[ -13]--------

 1    67  G_4   [0]     2     102    102    102        0
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Here, we can see that the imported data requires eight notes. Since it’s not a good idea to leave it with
just one note on a grid (this will not be useful when turning the individual patterns on and off in the
RTC Model/Control Surface), let’s split the notes between two patterns.

4. Turn on the “Split Notes into 3 Patterns” checkbox. This allows two split points for MIDI note
values to be used to separate the notes onto the three grids. In this case, the default split settings
seem to work well, as we’ve now got 4 notes on each of the first two grids.

5. Press Execute and check the results in the GE Editor and by playing it – try Chord Trigger 1 for a
minor chord. Try turning on and off Patterns 1 and 2 in the Real-Time Controls Editor (SW2, SW3). It
works pretty well, but I can see that it might be better if the top note (row #4) of Pattern 1 was
actually part of Pattern 2 instead.

6. Go back to the Import To GE Editor, and change the first split point from B3 down one semitone to
A#3. As you can see in the Analysis Area, we’ve taken the top note off Pattern 1 and moved it to
Pattern 2. Press [Execute] again and check the results – yes, this will be much better when trying to
use the patterns separately. You can also check out the variation on Pattern 3 that the system has
created based on moving around the notes of Pattern 1. This can be combined with the others to
increase the activity. You could go into Pattern 3 (by clicking on the Note Names next to the grid
in the GE Editor Drum Page) and set the Pattern Transpose parameter to +12 or +24 for additional
pitch variation.

7. We could go a bit further and try to use some of the additional rows in those two patterns for
additional velocity nuances. Turn on the “Split Into 3 Rows by Velocity” checkbox – this time we’ve
got a separate threshold for each pattern, because we have the “Split Notes into 3 Patterns”
checkbox above this section turned on. By experimenting, it seems that setting Pat1 to 106/117
and Pat 2 to 93/111 produces the maximum number of rows from this data.

Saving your work

When you press the [Execute] button in the Import To GE Editor, it creates a new GE in the location
you specify at the bottom of the window. However, the GE is installed into a temporarily Initialized
Performance in the Edit Buffer. In other words, if you presently have a single-module Performance (a
Program) selected, and you execute, it initializes the Edit Buffer Performance and installs the GE inside
it, so that you can audition it and work with it.

If you want to edit the Performance aspects,
you can, such as key zones, triggering
options and other settings in the
Performance Editor. However, you then
need to store that Performance somewhere,
if you want to keep what you’ve done. You do this using the [Store] button at the top of the
Performance Editor, next to the Bank and PE popup menus.

This saves the Performance that
references your newly imported GE into
the current KDF file. If you want to edit
the GE after it has been imported, or
rename it, you use the [Store] button at
the top of the GE Editor to save the changes, next to the Bank and GE popup menus. Both of these
actions save your work into the current KDF file, but this is only in RAM – you still need to save the KDF
file to your computer’s hard disk, like saving a text document that has been worked on. Use either
“Save” from the File Menu, or “Save As” to create a new file (and leave the original as it was).
When working on a GE within a Performance, the recommended sequence of saving your work goes
like this:
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1. Save the GEs that are part of the Performance, if they have been edited.
2. Save the Performance.
3. Save the KDF file.

Tips for creating Melodic Drum GEs

Phrases that are being imported should be in the key and tonality of Cmaj7, if you want them to be
able to follow different chord types and keys like you typically might expect from an arranger. KARMA
uses NTT (Note Transposition Tables) to map the notes to different chords, and this works best when
the notes have the elements of a Cmaj7 chord. In other words, let’s say you have a minor phrase in
mind. Record the phrase, but then, before importing it, change it to Cmaj7. Many external programs
have some sort of scale transposition features that can automate this, but if not, the idea is that all
minor 3rd (Eb) would be changed to a major 3rd (E), all dom7 or min7 (Bb) to a maj7 (B), etc. This can
make the phrase sound weird, but after you import it, it will follow chord changes because KARMA
does this in reverse.

If you simply want a completely fixed phrase that changes keys, but does not shift any of the notes to
other tonalities (for example, staying minor no matter what chord you play), it should still be in the key
of C when being imported. Then, in the resulting GE, turn off the NTT buttons on each of the three
Drum Patterns. This will follow the root note around, but will stay in a fixed chord.

When importing simple phrases, you want to optimize the settings in the window for good results. If
there are eight notes in the riff, you don't want seven of them on one pattern, and a single note on the
second pattern. This will be useless for turning the individual patterns on and off in the scenes. Rather,
change the Note Split point so that some notes end up on one pattern, and some on the other.

At that point, or alternately, you can also use the “Split By Velocities Into 3 Rows” feature, to get more
notes and more velocity levels. For example, if you already have to use two patterns, might as well try
to get seven notes or so in each pattern out of the phrase.

When you only create one or two patterns from the input data, the system creates a variation on the
original pattern for the empty grids, but turns them off by default. In the RTC Model, they can be
activated to provide variations and additional activity. Note that you can turn on Force Mono, and
then turn on 2 or 3 patterns at the same time, and only get one note at a particular moment - they will
fill in the spaces in each other and sometimes create interesting variations of the original.

It’s generally not necessary to worry about Duration Patterns when creating a drum GE, so this option
is off by default for the Drum Interpretation. (One possible exception would be if using a kit that has
“hold” turned of so that the durations of the notes are gating it. In this case, you might want to create
a Duration Pattern.)

Note: when working on Melodic Drum GEs, you can display Note Names instead of Drum Names next to the
Drum Pattern Grids. Use the Menu Button on the Drum Page (turn “Use GM Drum Names” off), or go to
Preferences > Popups > Drum Name Popup Menus > Use GM Drum Names -> Off.
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